<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="utf-8">
<link rel="canonical" href="https://www.thevow.ie/fashion-and-beauty/engagements/watch-i-just-took-a-chance-cork-man-stages-sweet-christmas-proposal-in-airport-arrivals-hall-37604210.html">
<link rel="amphtml" href="https://amp.thevow.ie/fashion-and-beauty/engagements/watch-i-just-took-a-chance-cork-man-stages-sweet-christmas-proposal-in-airport-arrivals-hall-37604210.html">
<link rel="alternate" media="only screen and (max-width: 640px)" href="https://amp.thevow.ie/fashion-and-beauty/engagements/watch-i-just-took-a-chance-cork-man-stages-sweet-christmas-proposal-in-airport-arrivals-hall-37604210.html">
<title>WATCH: &#039;I just took a chance!&#039; - Cork man stages sweet Christmas proposal in airport arrivals hall</title>
<meta name="description" content="A Cork man took his love to new heights when he pulled off a sweet festive proposal in an airport arrivals hall."/>
<meta name="news_keywords"
content="WATCH: &#039;I just took a chance!&#039; - Cork man stages sweet Christmas proposal in airport arrivals hall - TheVow.ie"/>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="IE=edge"/>
<script type="text/javascript" src="https://www.thevow.ie/static/810047bcd886d8acbd9423fa2f7902059ad1922c/js/thevow-modernizr.min.js"></script>
<link rel="stylesheet"
href="https://fonts.googleapis.com/css?family=Oxygen:300,400,700|Source+Sans+Pro:300,400,400i,600"/>
<script type="text/javascript">
window.lightbox = {displayAdsCount:3};
</script>
<link rel="stylesheet" type="text/css" href="https://www.thevow.ie/static/810047bcd886d8acbd9423fa2f7902059ad1922c/css/lightbox.min.css" media="screen"/>
<link rel="stylesheet" type="text/css" href="https://www.thevow.ie/static/810047bcd886d8acbd9423fa2f7902059ad1922c/css/thevow-app.min.css" media="screen"/>
<link rel="stylesheet" type="text/css" href="https://www.thevow.ie/static/810047bcd886d8acbd9423fa2f7902059ad1922c/css/thevow-print.min.css" media="print"/>
<link rel="shortcut icon" href="https://www.thevow.ie/img/thevow/favicon.ico" type="image/x-icon"/>
<script type="text/javascript">
window.publicationUrl = 'https://www.thevow.ie/';
window.publicationTitle = 'TheVow.ie';
window.breadcrumb = 'The Vow;Fashion & Beauty;Engagements';
</script>
<meta property="og:title" content="WATCH: &#039;I just took a chance!&#039; - Cork man stages sweet Christmas proposal in airport arrivals hall"/>
<meta property="og:site_name" content="TheVow.ie"/>
<meta property="og:description" content="A Cork man took his love to new heights when he pulled off a sweet festive proposal in an airport arrivals hall."/>
<meta property="og:url" content="https://www.thevow.ie/fashion-and-beauty/engagements/watch-i-just-took-a-chance-cork-man-stages-sweet-christmas-proposal-in-airport-arrivals-hall-37604210.html"/>
<meta property="og:type" content="article"/>
<meta property="og:image" content="https://www.independent.ie/incoming/article37604226.ece/ALTERNATES/h342/tyler-nix-499023-unsplash.jpg"/>
<meta property="og:image:type" content="image/jpeg"/>
<meta property="og:image:width" content="513"/>
<meta property="og:image:height" content="342"/>
<meta property="fb:app_id" content="714861305308164"/>
<link rel="alternate"
href="android-app://somefakesodonotopeninindoapp/http/www.thevow.ie/fashion-and-beauty/engagements/watch-i-just-took-a-chance-cork-man-stages-sweet-christmas-proposal-in-airport-arrivals-hall-37604210.html"/>
<meta name="apple-itunes-app"
content="app-id=somefakesodonotopeninindoapp, app-argument=http://www.thevow.ie/fashion-and-beauty/engagements/watch-i-just-took-a-chance-cork-man-stages-sweet-christmas-proposal-in-airport-arrivals-hall-37604210.html">
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "NewsArticle",
"headline": "WATCH: 'I just took a chance!' - Cork man stages sweet Christmas proposal in airport arrivals hall",
"inLanguage": "en",
"publisher": {
"@type": "Organization",
"name": "TheVow.ie",
"logo": {
"@type": "ImageObject",
"url": "https://cdn-01.independent.ie/incoming/article29621345.ece/BINARY/logo_web_368x47.png"
}
},
"image": {
"@type": "ImageObject",
"url": "https://www.independent.ie/incoming/article37604226.ece/ALTERNATES/h342/tyler-nix-499023-unsplash.jpg",
"height": "342",
"width": "513"
},
"mainEntityOfPage": {
"@type": "WebPage",
"@id": "https://www.thevow.ie/"
},
"dateCreated": "2018-12-07T12:18:45+0000",
"dateModified": "2018-12-07T12:32:47+0000",
"datePublished": "2018-12-07T12:32:47+0000",
"keywords": "",
"thumbnailUrl": "https://cdn-04.independent.ie/incoming/article37604226.ece/ALTERNATES/h342/tyler-nix-499023-unsplash.jpg",
"author": {
"@type": "Person",
"name": "THEVOW.ie"
}
}
</script>
<script src="https://consent.inm.ie/inmConsent.js" type="text/javascript"></script>
<script type="application/json" class="gpt-config">
{"targeting":{"art_id":"37604210","kw":["WATCH","I","just","took","a","chance","Cork","man","stages","sweet","Christmas","proposal","in","airport","arrivals","hall"]}}
</script>
<script type="application/json" class="prebid-config">
{"js":"https:\/\/www.thevow.ie\/static\/810047bcd886d8acbd9423fa2f7902059ad1922c\/js\/prebid.min.js"}
</script>
<script type="text/javascript">
var articleReadMoreEnabled = true;
</script>
</head>
<body data-domain="www.thevow.ie" data-section-name="Engagements" data-section-path="style/thevow/fashion-and-beauty/engagements/" data-article="WATCH: 'I just took a chance!' - Cork man stages sweet Christmas proposal in airport arrivals hall">
<script type="text/javascript">
dataLayer = [{"pageType":"article","pageSubCategory":"Engagements","pageCategory":"Fashion & Beauty","pageTitle":"WATCH: 'I just took a chance!' - Cork man stages sweet Christmas proposal in airport arrivals hall","pageAttributes":{"comments":"no","relatedArticles":"yes","videos":1,"source":"Online Editors","readMore":"yes","photos":1},"articleId":37604210,"sectionId":5175}];
window.dataLayerEvUpdate && window.dataLayerEvUpdate(dataLayer);
window.dataLayerACUpdate && window.dataLayerACUpdate(dataLayer);
</script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TVFQ43P"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-TVFQ43P');</script>
<!-- End Google Tag Manager -->
<!-- Begin BlueKai Tag -->
<script type="text/javascript">
if (!window.inmConsent || (inmConsent.getPublisherConsents().standardPurposeConsents[3] === true)) {
window.bk_async = function() {
bk_addPageCtx('ad_unit_2', 'Fashion_Beauty');
bk_addPageCtx('ad_unit_3', 'Engagements');
bk_addPageCtx('ad_unit_4', 'N/A');
BKTAG.doTag(48176, 4); };
(function() {
var scripts = document.getElementsByTagName('script')[0];
var s = document.createElement('script');
s.async = true;
s.src = "https://tags.bkrtx.com/js/bk-coretag.js";
scripts.parentNode.insertBefore(s, scripts);
}());
}
</script>
<!-- End BlueKai Tag -->
<div class="root-a is-loading">
<div class="wrap">
<header class="top-a" id="top">
<div class="wrap">
<div class="-contain">
<p class="logo"><a href="https://www.thevow.ie/" accesskey="h" class="icon-logo"><span>The Vow</span></a></p>
<nav class="skips-a">
<ul >
<li >
<a href="#nav" accesskey="n">Skip to navigation</a>
</li>
<li >
<a href="#content" accesskey="c">Skip to content</a>
</li>
<li >
<a href="#footer" accesskey="f">Skip to footer</a>
</li>
</ul>
</nav>
<nav class="nav">
<ul >
<li >
<a href="https://www.thevow.ie/getting-started/" >Getting Started</a><em> [1]</em>
</li>
<li >
<a href="https://www.thevow.ie/fashion-and-beauty/" >Fashion & Beauty</a><em> [1]</em>
</li>
<li >
<a href="https://www.thevow.ie/honeymoons/" >Honeymoons</a><em> [3]</em>
</li>
<li >
<a href="https://www.thevow.ie/real-weddings/" >Real Weddings</a><em> [2]</em>
</li>
<li >
<a href="https://www.thevow.ie/the-final-say/" >The Final Say</a><em> [3]</em>
</li>
<li >
<a href="https://listings.thevow.ie/" >Venues</a><em> [6]</em>
</li>
</ul>
</nav>
<div class="corner">
<form action="https://www.thevow.ie/search/" method="get" class="search">
<p class="label"><label for="f-topsearch" class="icon" data-search-toggle><i class="icon-search"><span>Search</span></i></label></p>
<p class="fields"><span><input type="text" name="q" id="f-topsearch" placeholder="Search this site..." /><button type="submit" class="button-a icon"><i class="icon-search"><span>Search</span></i></button></span></p>
</form>
<p class="follow">
<span class="label">Follow:</span> <a href="https://www.facebook.com/thevow.ie" class="icon-facebook"><span>Facebook</span></a> <a href="https://www.instagram.com/thevow.ie/" class="icon-instagram"><span>Instagram</span></a>
</p>
<p class="menu" data-nav-toggle><span>All Sections </span><i class="icon-menu"></i></p>
</div>
</div>
</div>
</header>
<nav class="nav-a">
<p class="close" data-nav-close></p>
<div class="wrap">
<div class="-contain">
<form action="https://www.thevow.ie/search/" method="get" class="search">
<p><input type="text" name="q" id="f-mobilesearch" placeholder="Search" /> <button type="submit" class="button-a icon"><i class="icon-search"><span>Search</span></i></button></p>
</form>
<ul class="main">
<li >
<a href="https://www.thevow.ie/getting-started/" >Getting Started</a>
<nav >
<ul >
<li >
<a href="https://www.thevow.ie/getting-started/checklists/" >Checklists</a>
</li>
<li >
<a href="https://www.thevow.ie/getting-started/reception/" >Reception</a>
</li>
<li >
<a href="https://www.thevow.ie/getting-started/trends/" >Trends</a>
</li>
<li >
<a href="https://www.thevow.ie/getting-started/competitions/" >Competitions</a>
</li>
</ul>
</nav>
</li>
<li >
<a href="https://www.thevow.ie/fashion-and-beauty/" >Fashion & Beauty</a>
<nav >
<ul >
<li >
<a href="https://www.thevow.ie/fashion-and-beauty/wedding-dresses/" >Wedding Dresses</a>
</li>
<li >
<a href="https://www.thevow.ie/fashion-and-beauty/the-bride/" >The Bride</a>
</li>
<li >
<a href="https://www.thevow.ie/fashion-and-beauty/the-groom/" >The Groom</a>
</li>
<li >
<a href="https://www.thevow.ie/fashion-and-beauty/bridal-party-and-guests/" >Bridal Party & Guests</a>
</li>
<li >
<a href="https://www.thevow.ie/fashion-and-beauty/engagements/" >Engagements</a>
</li>
<li >
<a href="https://www.thevow.ie/fashion-and-beauty/hair-and-make-up/" >Hair & Make up</a>
</li>
</ul>
</nav>
</li>
<li >
<a href="https://www.thevow.ie/honeymoons/" >Honeymoons</a>
<nav >
<ul >
<li >
<a href="https://www.thevow.ie/honeymoons/destination-spotlight/" >Destination Spotlight</a>
</li>
<li >
<a href="https://www.thevow.ie/honeymoons/hen-and-stag/" >Hen & Stag</a>
</li>
<li >
<a href="https://www.thevow.ie/honeymoons/real-honeymoons/" >Real Honeymoons</a>
</li>
</ul>
</nav>
</li>
<li >
<a href="https://www.thevow.ie/real-weddings/" >Real Weddings</a>
<nav >
<ul >
<li >
<a href="https://www.thevow.ie/real-weddings/your-big-day/" >Your Big Day</a>
</li>
<li >
<a href="https://www.thevow.ie/real-weddings/wedding-videos/" >Wedding Videos</a>
</li>
<li >
<a href="https://www.thevow.ie/real-weddings/celebrity-weddings/" >Celebrity Weddings</a>
</li>
<li >
<a href="https://www.thevow.ie/real-weddings/royal-weddings/" >Royal Weddings</a>
</li>
<li >
<a href="https://www.thevow.ie/real-weddings/your-big-day/submit-a-wedding-36056934.html" >Submit a Wedding</a>
</li>
</ul>
</nav>
</li>
<li >
<a href="https://www.thevow.ie/the-final-say/" >The Final Say</a>
<nav >
<ul >
<li >
<a href="https://www.thevow.ie/the-final-say/ask-the-expert/" >Ask The Expert</a>
</li>
<li >
<a href="https://www.thevow.ie/the-final-say/etiquette-and-speeches/" >Etiquette & Speeches</a>
</li>
<li >
<a href="https://www.thevow.ie/the-final-say/opinion/" >Opinion</a>
</li>
<li >
<a href="https://www.thevow.ie/the-final-say/polls-and-surveys/" >Polls & Surveys</a>
</li>
<li >
<a href="https://www.thevow.ie/the-final-say/wedding-talk/" >Wedding Talk</a>
</li>
</ul>
</nav>
</li>
<li >
<a href="https://listings.thevow.ie/" >Venues</a>
</li>
</ul>
<p class="follow">
<span class="label">Follow The Vow:</span> <a href="https://www.facebook.com/thevow.ie" class="icon-facebook"><span>Facebook</span></a> <a href="https://www.instagram.com/thevow.ie/" class="icon-instagram"><span>Instagram</span></a>
</p>
<p class="logo"><a href="http://www.independent.ie/" class="icon-independent"><span>Independent.ie</span></a></p>
</div>
</div>
</nav>
<section class="content-a" id="content">
<div class="wrap-a">
<div class="-contain">
<article class="story-a">
<header class="header -mb:1">
<figure class="image">
<img src="https://cdn-04.independent.ie/incoming/article37604226.ece/014f2/AUTOCROP/w960h530/tyler-nix-499023-unsplash.jpg" srcset="https://cdn-04.independent.ie/incoming/article37604226.ece/014f2/AUTOCROP/w480h265/tyler-nix-499023-unsplash.jpg 480w, https://cdn-04.independent.ie/incoming/article37604226.ece/014f2/AUTOCROP/w960h530/tyler-nix-499023-unsplash.jpg 960w, https://cdn-04.independent.ie/incoming/article37604226.ece/014f2/AUTOCROP/w1920h1060/tyler-nix-499023-unsplash.jpg 1920w" alt="" />
</figure>
<figure class="photo-a -w: no-print" style="display: none !important">
<a href="" rel="lightbox" data-href="https://cdn-01.independent.ie/incoming/article37604226.ece/014f2/BINARY/tyler-nix-499023-unsplash.jpg"> </a>
</figure>
<p class="brow h6"><a href="https://www.thevow.ie/fashion-and-beauty/engagements/">Engagements</a></p>
<h1 class="title">WATCH: 'I just took a chance!' - Cork man stages sweet Christmas proposal in airport arrivals hall</h1>
<p class="lead h3">'Tis the season after all!</p>
<div class="socials-a -mt:1">
<ul>
<li class="facebook"><a href="https://www.facebook.com/dialog/share?app_id=714861305308164&href=https%3A%2F%2Fwww.thevow.ie%2Ffashion-and-beauty%2Fengagements%2Fwatch-i-just-took-a-chance-cork-man-stages-sweet-christmas-proposal-in-airport-arrivals-hall-37604210.html" target="_blank"><i class="icon-facebook"><span>Facebook</span></i></a></li>
<li class="twitter"><a href="https://twitter.com/intent/tweet?text=WATCH%3A%20%27I%20just%20took%20a%20chance%21%27%20-%20Cork%20man%20stages%20sweet%20Christmas%20proposal%20in%20airport%20arrivals%20hall&url=https%3A%2F%2Fwww.thevow.ie%2Ffashion-and-beauty%2Fengagements%2Fwatch-i-just-took-a-chance-cork-man-stages-sweet-christmas-proposal-in-airport-arrivals-hall-37604210.html&via=Independent_ie" target="_blank"><i class="icon-twitter"><span>Twitter</span></i></a></li>
<li class="pinterest"><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.thevow.ie%2Ffashion-and-beauty%2Fengagements%2Fwatch-i-just-took-a-chance-cork-man-stages-sweet-christmas-proposal-in-airport-arrivals-hall-37604210.html&description=WATCH%3A%20%27I%20just%20took%20a%20chance%21%27%20-%20Cork%20man%20stages%20sweet%20Christmas%20proposal%20in%20airport%20arrivals%20hall" data-pin-do="buttonBookmark" data-pin-custom="true" data-pin-media="https://www.independent.ie/incoming/article37604226.ece/ALTERNATES/h342/tyler-nix-499023-unsplash.jpg" target="_blank"><i class="icon-pinterest"><span>Pinterest</span></i></a></li>
<li class="email"><a href="mailto:?subject=WATCH%3A%20%27I%20just%20took%20a%20chance%21%27%20-%20Cork%20man%20stages%20sweet%20Christmas%20proposal%20in%20airport%20arrivals%20hall%20-%20TheVow.ie&body=WATCH%3A%20%27I%20just%20took%20a%20chance%21%27%20-%20Cork%20man%20stages%20sweet%20Christmas%20proposal%20in%20airport%20arrivals%20hall%0A%0Ahttps%3A%2F%2Fwww.thevow.ie%2Ffashion-and-beauty%2Fengagements%2Fwatch-i-just-took-a-chance-cork-man-stages-sweet-christmas-proposal-in-airport-arrivals-hall-37604210.html" target="_top"><i class="icon-email"><span>Email</span></i></a></li>
<li class="whatsapp"><a href="whatsapp://send?text=https%3A%2F%2Fwww.thevow.ie%2Ffashion-and-beauty%2Fengagements%2Fwatch-i-just-took-a-chance-cork-man-stages-sweet-christmas-proposal-in-airport-arrivals-hall-37604210.html"><i class="icon-whatsapp"><span>Whatsapp</span></i></a></li>
<li class="messenger"><a href="fb-messenger://share/?link=https%3A%2F%2Fwww.thevow.ie%2Ffashion-and-beauty%2Fengagements%2Fwatch-i-just-took-a-chance-cork-man-stages-sweet-christmas-proposal-in-airport-arrivals-hall-37604210.html&app_id=714861305308164"><i class="icon-messenger"><span>Messenger</span></i></a></li>
</ul>
</div>
<p>A Cork man took his love to new heights when he pulled off a sweet festive proposal in an airport arrivals hall. </p>
</header>
<section class="main">
<p>Ken Wills popped the question to Deborah Kirby in Cork Airport last night, after arranging for their special moment to be captured on camera.</p>
<p>Ken, who was flying into Cork from Heathrow, enlisted the help of airport staff to help him surprise his now bride-to-be with his sweet proposal, which was captured by Cork-based media production company, Isla Media.</p>
<div class="block-a">
<div class="slot-a">
<p class="label">Advertisement</p>
<script type="application/json" class="ad-slot">
{"id":"gpt-ad-36045939-5175","sizes":[[300,300],[300,250],[300,251]],"adUnit":"7380\/The_Vow\/Fashion_Beauty\/Engagements","targeting":{"pos":["article_mpu","article_roadblock"]}}
</script>
</div>
<p><strong>Related</strong>: <a href="https://www.thevow.ie/fashion-and-beauty/engagements/thevow-ie-engagement-guide-the-most-beautiful-places-to-propose-in-ireland-36340560.html">THEVOW.ie engagement guide: The most beautiful places to propose in Ireland</a>
</p>
<p>As an unsuspecting Deborah waited for his arrival, her favourite song - Woman by John Lennon - began playing before Ken appeared. As he entered the arrivals hall Ken dropped to one knee and asked her to be his wife.</p>
<p>Cork Airport Managing Director Niall MacCarthy said: “When Ken reached out and asked for assistance to plan the perfect proposal, we were delighted to help. It was the perfect ruse. We recruited a camera crew, who pretended to film the live Christmas music being performed at the airport daily throughout December and arranged for The Loungeman to play Deborah’s favourite song. It was lovely to help this great couple capture this beautiful moment.</p>
</div>
<p>“After the proposal, airport staff, Aer Lingus crew and the couple toasted with a glass of champagne. We offer Deborah and Ken a heartfelt congratulations from everyone at Cork Airport.”</p>
<div class="widget video vms" itemprop="video" itemscope itemtype="http://schema.org/VideoObject">
<script type="text/javascript" async src="//independent.bbvms.com/p/new_skin_test/c/3219787.js?dart_section=style_thevow_fashionandbeauty_engagements&dfp_adunit_l2=Fashion_Beauty&dfp_adunit_l1=The_Vow&callback=_bbcb&dfp_adunit_l3=Engagements&dart_playout=new_skin_test&dart_kw=%2CWATCH%2CI%2Cjust%2Ctook%2Ca%2Cchance%2CCork%2Cman%2Cstages%2Csweet%2CChristmas%2Cproposal%2Cin%2Cairport%2Carrivals%2Chall&dart_articleId=37604167"></script>
</div>
<p>Ken revealed he thought the airport would be the perfect proposal location as airports have a special place in the couple’s hearts. </p>
<p>“We first saw each other, after 15 years, six years ago in an airport. And have been dating since,” he said, adding that while he had been thinking about the proposal for some time, he only “plucked up the courage” on Wednesday night to email the airport and see whether they could work together on a magical Christmas surprise. </p>
<p>“I just took a chance,” he said.</p>
<p>The couple have three children, Aaron (19), Robin (13) and Harry (8).</p>
<p>The Loungeman, who serenaded the couple on the night, has offered to perform at their wedding for free as a wedding gift.</p>
</section>
<footer class="footer">
<div class="section-a">
<p class="byline-a">Words by <a href="./" class="author" rel="author">THEVOW.ie</a>
<time>07 December 2018 12:32 PM</time>
</p>
</div>
<p class="originalSource">
Online Editors
</p>
<div class="section-a">
<h4 class="hx">Related</h4>
<div class="related-a">
<div class="items -grid">
<div class="item -w:33">
<article class="teaser-a">
<figure class="image">
<a class="img-a" href="https://www.thevow.ie/fashion-and-beauty/engagements/from-toy-rings-to-proposing-in-pyjamas-how-not-to-pop-the-question-over-christmas-37603816.html" style="padding-top: 55%">
<img data-src="https://cdn-01.independent.ie/incoming/article37603760.ece/3a5c2/AUTOCROP/w800h440/bethany-laird-311248.jpg" alt="https://cdn-01.independent.ie/incoming/article37603760.ece/3a5c2/AUTOCROP/w800h440/bethany-laird-311248.jpg" />
</a>
</figure>
<p class="brow">
<a href="https://www.thevow.ie/fashion-and-beauty/engagements/">Engagements</a>
</p>
<h5 class="title">
<a href="https://www.thevow.ie/fashion-and-beauty/engagements/from-toy-rings-to-proposing-in-pyjamas-how-not-to-pop-the-question-over-christmas-37603816.html">From toy rings to proposing in pyjamas: How NOT to pop the question over Christmas</a>
</h5>
</article>
</div>
<div class="item -w:33">
<article class="teaser-a">
<figure class="image">
<a class="img-a" href="https://www.thevow.ie/fashion-and-beauty/engagements/thevow-ie-engagement-guide-the-most-beautiful-places-to-propose-in-ireland-36340560.html" style="padding-top: 55%">
<img data-src="https://cdn-03.independent.ie/incoming/article36340549.ece/6d47e/AUTOCROP/w800h440/engagement-ireland-niamh-smith-glendalough-6.png" alt="https://cdn-03.independent.ie/incoming/article36340549.ece/6d47e/AUTOCROP/w800h440/engagement-ireland-niamh-smith-glendalough-6.png" />
</a>
</figure>
<p class="brow">
<a href="https://www.thevow.ie/fashion-and-beauty/engagements/">Engagements</a>
</p>
<h5 class="title">
<a href="https://www.thevow.ie/fashion-and-beauty/engagements/thevow-ie-engagement-guide-the-most-beautiful-places-to-propose-in-ireland-36340560.html">THEVOW.ie engagement guide: The most beautiful places to propose in Ireland</a>
</h5>
</article>
</div>
<div class="item -w:33">
<article class="teaser-a">
<figure class="image">
<a class="img-a" href="https://www.thevow.ie/fashion-and-beauty/engagements/found-couple-delighted-after-police-rescue-engagement-ring-from-new-york-grate-37593406.html" style="padding-top: 55%">
<img data-src="https://cdn-01.independent.ie/incoming/article37588090.ece/0ffff/AUTOCROP/w800h440/ipanews_72a7dec2-68d7-4bca-875c-e839470fab5e_1" alt="https://cdn-01.independent.ie/incoming/article37588090.ece/0ffff/AUTOCROP/w800h440/ipanews_72a7dec2-68d7-4bca-875c-e839470fab5e_1" />
</a>
</figure>
<p class="brow">
<a href="https://www.thevow.ie/fashion-and-beauty/engagements/">Engagements</a>
</p>
<h5 class="title">
<a href="https://www.thevow.ie/fashion-and-beauty/engagements/found-couple-delighted-after-police-rescue-engagement-ring-from-new-york-grate-37593406.html">Found! Couple delighted after police rescue engagement ring from New York grate</a>
</h5>
</article>
</div>
<div class="item -w:33">
<article class="teaser-a">
<figure class="image">
<a class="img-a" href="https://www.thevow.ie/the-final-say/wedding-talk/i-was-in-my-tracksuit-bottoms-happily-bra-free-in-my-fluffy-hoody-people-are-sharing-their-notsoperfect-proposal-stories-and-theyre-quite-funny-indeed-37426438.html" style="padding-top: 55%">
<img data-src="https://cdn-04.independent.ie/incoming/article37426413.ece/41009/AUTOCROP/w800h440/austin-pacheco-701782-unsplash.jpg" alt="https://cdn-04.independent.ie/incoming/article37426413.ece/41009/AUTOCROP/w800h440/austin-pacheco-701782-unsplash.jpg" />
</a>
</figure>
<p class="brow">
<a href="https://www.thevow.ie/the-final-say/wedding-talk/">Wedding Talk</a>
</p>
<h5 class="title">
<a href="https://www.thevow.ie/the-final-say/wedding-talk/i-was-in-my-tracksuit-bottoms-happily-bra-free-in-my-fluffy-hoody-people-are-sharing-their-notsoperfect-proposal-stories-and-theyre-quite-funny-indeed-37426438.html">'I was in my tracksuit bottoms, happily bra free in my fluffy hoody' - People are sharing their not-so-perfect proposal stories and they're quite funny indeed</a>
</h5>
</article>
</div>
<div class="item -w:33">
<article class="teaser-a">
<figure class="image">
<a class="img-a" href="https://www.thevow.ie/fashion-and-beauty/engagements/she-said-yes-under-the-northern-lights-philly-mcmahons-engagement-looks-incredible-37586907.html" style="padding-top: 55%">
<img data-src="https://cdn-03.independent.ie/incoming/article37586909.ece/7cb6e/AUTOCROP/w800h440/Philly%20engagement.jpg" alt="https://cdn-03.independent.ie/incoming/article37586909.ece/7cb6e/AUTOCROP/w800h440/Philly%20engagement.jpg" />
</a>
</figure>
<p class="brow">
<a href="https://www.thevow.ie/fashion-and-beauty/engagements/">Engagements</a>
</p>
<h5 class="title">
<a href="https://www.thevow.ie/fashion-and-beauty/engagements/she-said-yes-under-the-northern-lights-philly-mcmahons-engagement-looks-incredible-37586907.html">'She said yes under the Northern Lights' - Philly McMahon's engagement looks incredible</a>
</h5>
</article>
</div>
<div class="item -w:33">
<article class="teaser-a">
<figure class="image">
<a class="img-a" href="https://www.thevow.ie/fashion-and-beauty/engagements/watch-you-could-say-it-was-a-bit-of-a-shock-sweet-moment-young-irish-couple-gets-engaged-at-kodaline-gig-37255230.html" style="padding-top: 55%">
<img data-src="https://cdn-03.independent.ie/incoming/article36400649.ece/cf727/AUTOCROP/w800h440/GettyImages-811013948.jpg" alt="https://cdn-03.independent.ie/incoming/article36400649.ece/cf727/AUTOCROP/w800h440/GettyImages-811013948.jpg" />
</a>
</figure>
<p class="brow">
<a href="https://www.thevow.ie/fashion-and-beauty/engagements/">Engagements</a>
</p>
<h5 class="title">
<a href="https://www.thevow.ie/fashion-and-beauty/engagements/watch-you-could-say-it-was-a-bit-of-a-shock-sweet-moment-young-irish-couple-gets-engaged-at-kodaline-gig-37255230.html">WATCH: 'You could say it was a bit of a shock' - Sweet moment young Irish couple gets engaged at Kodaline gig</a>
</h5>
</article>
</div>
</div>
</div>
</div>
</footer>
</article>
<!-- RW: 36057448 k: reference-default-36057448-sec-style_thevow_fashionandbeauty_engagements-art e: 20m d: -->
<div class="featured-a -expand">
<div class="-contain">
<h4>Find your perfect venue</h4> <div class="items">
<div class="item">
<article class="teaser-b">
<a href="https://listings.thevow.ie/venues/ferrycarrig-hotel">
<p class="badge"><span>Featured</span></p> <figure class="image">
<span class="img-a" style="padding-top: 55%">
<img src="https://listings.thevow.ie/uploads/20180206_3a35442a1b3a7b9a5d2450b22b15fb8b_2453.jpg" alt="" />
</span>
</figure>
<h5 class="title" data-equalize><span>Ferrycarrig Hotel</span></h5>
<ul class="details">
<li><small>Capacity</small> <strong>270</strong></li>
<li><small>Price Per Person</small> <strong>&euro;46 - &euro;60</strong></li>
</ul>
</a>
</article>
</div><div class="item">
<article class="teaser-b">
<a href="https://listings.thevow.ie/venues/the-g-hotel-spa">
<p class="badge"><span>Featured</span></p> <figure class="image">
<span class="img-a" style="padding-top: 55%">
<img src="https://listings.thevow.ie/uploads/20180219_39827cb376b8ba13a1de8b43946c9cdc_1394.jpg" alt="" />
</span>
</figure>
<h5 class="title" data-equalize><span>The g Hotel & Spa</span></h5>
<ul class="details">
<li><small>Capacity</small> <strong>200</strong></li>
<li><small>Price Per Person</small> <strong>&euro;60 - &euro;74</strong></li>
</ul>
</a>
</article>
</div><div class="item">
<article class="teaser-b">
<a href="https://listings.thevow.ie/venues/clayton-hotel-dublin-airport">
<figure class="image">
<span class="img-a" style="padding-top: 55%">
<img src="https://listings.thevow.ie/uploads/ClaytonDublinAirportHotel_VF_002Teaser--439.jpg" alt="" />
</span>
</figure>
<h5 class="title" data-equalize><span>Clayton Hotel Dublin Airport</span></h5>
<ul class="details">
<li><small>Capacity</small> <strong>250</strong></li>
<li><small>Price Per Person</small> <strong>&euro;50 - &euro;59</strong></li>
</ul>
</a>
</article>
</div><div class="item">
<article class="teaser-b">
<a href="https://listings.thevow.ie/venues/castlemartyr-resort">
<figure class="image">
<span class="img-a" style="padding-top: 55%">
<img src="https://listings.thevow.ie/uploads/CastlemartyrResort_VF_teaser--123.jpg" alt="" />
</span>
</figure>
<h5 class="title" data-equalize><span>Castlemartyr Resort</span></h5>
<ul class="details">
<li><small>Capacity</small> <strong>320</strong></li>
<li><small>Price Per Person</small> <strong>&euro;78 - &euro;129</strong></li>
</ul>
</a>
</article>
</div><div class="item">
<article class="teaser-b">
<a href="https://listings.thevow.ie/venues/lough-rynn-castle-hotel">
<figure class="image">
<span class="img-a" style="padding-top: 55%">
<img src="https://listings.thevow.ie/uploads/LoughRynnCastleEstateandGardens_VF_teaser--221.jpg" alt="" />
</span>
</figure>
<h5 class="title" data-equalize><span>Lough Rynn Castle Hotel</span></h5>
<ul class="details">
<li><small>Capacity</small> <strong>320</strong></li>
<li><small>Price Per Person</small> <strong>&euro;67 - &euro;80</strong></li>
</ul>
</a>
</article>
</div><div class="item">
<article class="teaser-b">
<a href="https://listings.thevow.ie/venues/carlton-hotel-blanchardstown">
<figure class="image">
<span class="img-a" style="padding-top: 55%">
<img src="https://listings.thevow.ie/uploads/CarltonHotelBlanchardstown_wd_002_teaser--106.jpg" alt="" />
</span>
</figure>
<h5 class="title" data-equalize><span>Carlton Hotel Blanchardstown</span></h5>
<ul class="details">
<li><small>Capacity</small> <strong>350</strong></li>
<li><small>Price Per Person</small> <strong>&euro;75 - &euro;99</strong></li>
</ul>
</a>
</article>
</div><div class="item">
<article class="teaser-b">
<a href="https://listings.thevow.ie/venues/maryborough-hotel-spa">
<figure class="image">
<span class="img-a" style="padding-top: 55%">
<img src="https://listings.thevow.ie/uploads/20171127_725544181668de181aa48e94331ed9bb_167.jpg" alt="" />
</span>
</figure>
<h5 class="title" data-equalize><span>Maryborough Hotel & Spa</span></h5>
<ul class="details">
<li><small>Capacity</small> <strong>300</strong></li>
<li><small>Price Per Person</small> <strong>&euro;60 - &euro;74</strong></li>
</ul>
</a>
</article>
</div><div class="item">
<article class="teaser-b">
<a href="https://listings.thevow.ie/venues/belleek-castle">
<figure class="image">
<span class="img-a" style="padding-top: 55%">
<img src="https://listings.thevow.ie/uploads/BelleekCastle_VI_teaser--136.png" alt="" />
</span>
</figure>
<h5 class="title" data-equalize><span>Belleek Castle</span></h5>
<ul class="details">
<li><small>Capacity</small> <strong>200</strong></li>
<li><small>Price Per Person</small> <strong>&euro;75 - &euro;99</strong></li>
</ul>
</a>
</article>
</div><div class="item">
<article class="teaser-b">
<a href="https://listings.thevow.ie/venues/brooklodge-macreddin-village">
<figure class="image">
<span class="img-a" style="padding-top: 55%">
<img src="https://listings.thevow.ie/uploads/BrooklodgeandMacreddinVillage_VF_teaser--155.png" alt="" />
</span>
</figure>
<h5 class="title" data-equalize><span>Brooklodge & Macreddin Village, County Wicklow</span></h5>
<ul class="details">
<li><small>Capacity</small> <strong>180</strong></li>
<li><small>Price Per Person</small> <strong>&euro;97 - &euro;120</strong></li>
</ul>
</a>
</article>
</div><div class="item">
<article class="teaser-b">
<a href="https://listings.thevow.ie/venues/coolbawn-quay">
<figure class="image">
<span class="img-a" style="padding-top: 55%">
<img src="https://listings.thevow.ie/uploads/CoolbawnQuay_VI_teaser--686.png" alt="" />
</span>
</figure>
<h5 class="title" data-equalize><span>Coolbawn Quay</span></h5>
<ul class="details">
<li><small>Capacity</small> <strong>220</strong></li>
<li><small>Price Per Person</small> <strong>&euro;99 - &euro;115</strong></li>
</ul>
</a>
</article>
</div> </div>
</div>
</div>
</div>
</div>
</section>
<footer class="footer-a" id="footer">
<div class="-contain">	<p class="logo">
<a href="https://www.thevow.ie/">
<i class="icon-logo echo"></i>
<i class="icon-logo main">
<span>The Vow
</span></i></a>
</p>	<div class="socials-a">	<ul>	<li class="facebook">
<a href="https://www.facebook.com/thevow.ie">
<i class="icon-facebook">
<span>Facebook
</span></i></a>
</li>	<li class="instagram">
<a href="https://www.instagram.com/thevow.ie/">
<i class="icon-instagram">
<span>Instagram
</span></i></a>
</li>	</ul>	</div>	<hr class="-expand">	<ul class="links">	<li>
<a href="https://www.thevow.ie/contact-us-36056480.html">Contact Us</a>
</li>	<li>
<a href="https://www.thevow.ie/terms-and-conditions-for-the-vow-36056486.html">Terms & Conditions</a>
</li>	<li>
<a href="https://www.thevow.ie/privacy-statement-for-the-vow-36056485.html">Privacy Statement</a>
</li>	<li>
<a href="https://www.thevow.ie/services/cookie-policy-the-vow-36941937.html">Cookie Policy</a>
</li>	<li>
<a href="http://www.inm.ie/products/">Group Websites</a>
</li>	</ul>	<ul class="logos">	<li>
<a href="http://www.independent.ie/">
<i class="icon-independent">
<span>Independent.ie
</span></i></a>
</li>	<li class="inm">
<a href="http://www.inmplc.com/">An <i class="icon-inm">
<span>INM
</span></i> Website</a>
</li>	</ul>	</div>
</footer>
</div>
</div>
<script type="text/javascript">
//<![CDATA[
var clientDT = new Date().getTime();
document.write('<img style="display:none;" src="https://www.independent.ie/analysis-logger/?rt=1&ctxId=5175&pubId=1&cat=&meta=read-news&objId=37604210&type=article&title=WATCH%3a+%26%23039%3bI+just+took+a+chance!%26%23039%3b+-+Cork+man+stages+sweet+Christmas+proposal+in+airport+arrivals+hall&url=https%3a%2f%2fwww.thevow.ie%2ffashion-and-beauty%2fengagements%2fwatch-i-just-took-a-chance-cork-man-stages-sweet-christmas-proposal-in-airport-arrivals-hall-37604210.html&amp;clientDT=' + clientDT + '" alt="" width="1" height="1"/>');
//]]>
</script>
<noscript>
<div>
<img src="https://www.independent.ie/analysis-logger/?rt=1&amp;ctxId=5175&amp;pubId=1&amp;cat=&amp;meta=read-news&amp;objId=37604210&amp;type=article&amp;title=WATCH%3a+%26%23039%3bI+just+took+a+chance!%26%23039%3b+-+Cork+man+stages+sweet+Christmas+proposal+in+airport+arrivals+hall&amp;url=https%3a%2f%2fwww.thevow.ie%2ffashion-and-beauty%2fengagements%2fwatch-i-just-took-a-chance-cork-man-stages-sweet-christmas-proposal-in-airport-arrivals-hall-37604210.html" alt="one pixel graphics" width="1" height="1"/>
</div>
</noscript>
<script type='text/javascript'>
var getCookie = function(key) {
var cookies = document.cookie.split('; ');
for (var i = 0, parts; (parts = cookies[i] && cookies[i].split('=')); i++) {
if (parts.shift() === key) {
var cookieValue = parts.join('=');
if (cookieValue) cookieValue = decodeURIComponent(cookieValue);
return cookieValue;
}
}
};
var _sf_async_config={};
/** CONFIGURATION START **/
_sf_async_config.uid = 51545;
_sf_async_config.domain = 'independent.ie';
_sf_async_config.autoDetect = false;
_sf_async_config.path = "/thevow//fashion-and-beauty/engagements/article-37604210.html";
_sf_async_config.sections = "The Vow,The Vow_Fashion & Beauty,The Vow_Fashion & Beauty_Engagements";
_sf_async_config.authors = "THEVOW.ie";
var _cbq = window._cbq = (window._cbq || []);
_cbq.push(['_acct', getCookie('guid') ? 'lgdin' : 'anon']);
/** CONFIGURATION END **/
(function() {
var e = document.createElement('script');
e.type = 'text/javascript';
e.async = true;
e.src = 'https://www.thevow.ie/static/810047bcd886d8acbd9423fa2f7902059ad1922c/js/bluebillywig-chartbeat.min.js';
document.body.appendChild(e);
})();
</script>
<script type="text/javascript" src="https://www.thevow.ie/static/810047bcd886d8acbd9423fa2f7902059ad1922c/js/thevow-libs.min.js"></script>
<script type="text/javascript" src="https://www.thevow.ie/static/810047bcd886d8acbd9423fa2f7902059ad1922c/js/lightbox.min.js"></script>
<script type="text/javascript" src="https://www.thevow.ie/static/810047bcd886d8acbd9423fa2f7902059ad1922c/js/thevow-app.min.js"></script>
<script type="text/javascript" src="https://www.thevow.ie/static/810047bcd886d8acbd9423fa2f7902059ad1922c/js/tracking.min.js"></script>
<script src="https://consent.inm.ie/thevow/quantcastsettings.js" type="text/javascript"></script>
<script async type="text/javascript" src="https://www.thevow.ie/static/810047bcd886d8acbd9423fa2f7902059ad1922c/js/inm-ai.js"></script>
</body>
</html>
